restore ABI level 5 compatibility