release prep: update font handlers to depend on next release
authorTony Cook <tony@develop-help.com>
Fri, 19 Apr 2013 11:06:51 +0000 (21:06 +1000)
committerTony Cook <tony@develop-help.com>
Fri, 19 Apr 2013 11:06:51 +0000 (21:06 +1000)
They need new code in Imager::Test.

FT2/Changes
FT2/FT2.pm
FT2/Makefile.PL
T1/Changes
T1/Makefile.PL
T1/T1.pm
W32/Changes
W32/Makefile.PL
W32/W32.pm

index d61256facc243b91f48d09f00f4493b748cb0001..f72bcbd50ef34c02b17e8b1156c38d43769eb955 100644 (file)
@@ -1,6 +1,13 @@
+Imager-Font-FT2 0.91
+====================
+
+ - depend on Imager 0.95.
+
 Imager-Font-FT2 0.90
 ====================
 
+Released as part of Imager 0.94_02.
+
  - fix some mismatched format strings/types
 
  - enable the debug log for t/t90std.t
index e758d02e31f33f61b2f6f35dfbb0238cacc3e1c0..4d1fec90e69c80615f9a5d5bfeba603f08665882 100644 (file)
@@ -6,7 +6,7 @@ use vars qw($VERSION @ISA);
 @ISA = qw(Imager::Font);
 
 BEGIN {
-  $VERSION = "0.90";
+  $VERSION = "0.91";
 
   require XSLoader;
   XSLoader::load('Imager::Font::FT2', $VERSION);
index 86ccab7b03c3271aa4b3246b78063387416eed62..b2925be5cf3b1b3b00fdc164bfcb8fbd06541143 100644 (file)
@@ -38,7 +38,7 @@ else {
   $opts{TYPEMAPS} = [ Imager::ExtUtils->typemap ];
 
   # Imager required configure through use
-  my @Imager_req = ( Imager => "0.94" );
+  my @Imager_req = ( Imager => "0.95" );
   if ($MM_ver >= 6.46) {
     $opts{META_MERGE} =
       {
index 09ed18732db0b7acd6aadfdad7178bc864370834..b80a75a64183758448cda7e44ea61473a4b18d5c 100644 (file)
@@ -1,6 +1,13 @@
+Imager::Font::T1 1.022
+======================
+
+ - depend on Imager 0.95.
+
 Imager::Font::T1 1.021
 ======================
 
+Released as part of Imager 0.94_02.
+
  - enable the debug log for t/t90std.t
 
  - add typemap to the manifest, this caused build failures in 1.020.
index c798e180a8c8de8f58612dfb1cb09708a5a3e416..fd8fa648a64a8cd12b38d2c5cf7561b77befad80 100644 (file)
@@ -38,7 +38,7 @@ else {
   $opts{TYPEMAPS} = [ Imager::ExtUtils->typemap ];
 
   # Imager required configure through use
-  my @Imager_req = ( Imager => "0.94" );
+  my @Imager_req = ( Imager => "0.95" );
   if ($MM_ver >= 6.46) {
     $opts{META_MERGE} =
       {
index 42f3fa04efbced6d93c936f4f78cd2022c8f1014..84a66a20f7c72e5d1a82f94502e2ae2dd0822bb3 100644 (file)
--- a/T1/T1.pm
+++ b/T1/T1.pm
@@ -6,7 +6,7 @@ use vars qw(@ISA $VERSION);
 use Scalar::Util ();
 
 BEGIN {
-  $VERSION = "1.021";
+  $VERSION = "1.022";
 
   require XSLoader;
   XSLoader::load('Imager::Font::T1', $VERSION);
index 15b11af0d56f94de3e63d6e723e8f4b12f2b702a..c0e695cbd97ea80f5a4192e7ca30c6209ac4e755 100644 (file)
@@ -1,3 +1,15 @@
+Imager-Font-W32 0.87
+====================
+
+ - depend on Imager 0.95.
+
+Imager-Font-W32 0.86
+====================
+
+Released as part of a development release of Imager.
+
+ - add standard font tests
+
 Imager-Font-W32 0.85
 ====================
 
index cf66fd703c7bb544d4fb90bc2b1820fe7118ba78..c729a4ad93986f585e533367ee01d155d60d1d22 100644 (file)
@@ -38,7 +38,7 @@ else {
   $opts{TYPEMAPS} = [ Imager::ExtUtils->typemap ];
 
   # Imager required configure through use
-  my @Imager_req = ( Imager => "0.86" );
+  my @Imager_req = ( Imager => "0.95" );
   if ($MM_ver >= 6.46) {
     $opts{META_MERGE} =
       {
index d8da606762503e3ec77d1a93ea2cc778d0847b78..6467985216caea3f6ef418f1de573620f34acc74 100644 (file)
@@ -5,7 +5,7 @@ use vars qw($VERSION @ISA);
 @ISA = qw(Imager::Font);
 
 BEGIN {
-  $VERSION = "0.86";
+  $VERSION = "0.87";
 
   require XSLoader;
   XSLoader::load('Imager::Font::W32', $VERSION);