update desired debian packages
[imager.git] / lib / Imager / Install.pod
index 5e8234b..3d5f9a9 100644 (file)
@@ -145,10 +145,12 @@ X<< C<libpng> >>L<Imager::File::PNG> uses L<< C<libpng>
 |http://www.libpng.org/pub/png/libpng.html >> for PNG image file
 support.
 
-Debian package: C<libpng12-dev>
+Debian package: C<libpng-dev>
 
 Redhat package: C<libpng-devel>
 
+Cygwin: C<libpng-devel>
+
 =head2 TIFF - C<libtiff>
 
 X<< C<libtiff> >>L<Imager::File::TIFF> uses
@@ -166,6 +168,8 @@ Debian package: C<libtiff4-dev>
 
 Redhat package: C<libtiff-devel>
 
+Cygwin: C<libtiff-devel>
+
 =head2 GIF - C<libgif>
 
 X<< C<libgif> >>L<Imager::File::GIF> uses
@@ -185,6 +189,8 @@ Debian package: C<libgif-dev>
 
 Redhat package: C<giflib-devel>
 
+Cygwin: C<libgif-devel>
+
 =head2 JPEG - C<libjpeg>
 
 L<Imager::File::JPEG> uses L<< C<libjpeg> |http://www.ijg.org/ >> for JPEG
@@ -203,7 +209,9 @@ binaries.
 
 Redhat package: C<libjpeg-devel>
 
-Debian package: C<libjpeg8-dev>
+Debian package: C<libjpeg-dev>
+
+Cygwin: C<libjpeg-devel>
 
 =head2 Freetype 2.x - C<libfreetype>
 
@@ -217,6 +225,8 @@ Debian package: C<libfreetype6-dev>
 
 Redhat package: C<freetype-devel>
 
+Cygwin: C<libfreetype-devel>
+
 =head2 Win32 GDI fonts
 
 L<Imager::Font::W32> uses L<Win32
@@ -234,6 +244,12 @@ C<w32api-runtime> packages.
 L<Imager::Font::T1> uses L<< C<t1lib> |http://www.t1lib.org/ >> for
 font support, supporting Postscript Type 1 fonts only.
 
+T1Lib is abandonware, the latest released version has several bugs
+that reliably crash on 64-bit systems.
+
+Expect C<Imager::Font::T1> to be unbundled from the Imager
+distribution at some point.
+
 Debian package: C<libt1-dev>
 
 Redhat package: C<t1lib-devel>
@@ -246,6 +262,8 @@ available for font support, supporting TTF fonts only.
 Freetype 1.x is essentially unsupported and shouldn't be used for new
 code.
 
+Expect Freetype 1 support to be removed from Imager at some point.
+
 =head1 PLATFORM SPECIFICS
 
 =head2 Linux
@@ -376,7 +394,8 @@ or possibly, just:
 
   $ perlrebase
 
-will fix the problem.
+will fix the problem.  64-bit Cygwin significantly reduces occurrences
+of this problem.
 
 =head1 Other issues