we require perl 5.6.
[imager-graph.git] / Makefile.PL
1 #!perl -w
2 use strict;
3 require 5.006;
4 use ExtUtils::MakeMaker;
5 my %opts;
6 # eval to prevent warnings about versions with _ in them
7 my $MM_ver = eval $ExtUtils::MakeMaker::VERSION;
8 if ($MM_ver > 6.06) {
9   $opts{AUTHOR} = 'Tony Cook <tony@develop-help.com>';
10   $opts{ABSTRACT} = 'Draws good looking charts';
11 }
12 if ($MM_ver >= 6.31) {
13   $opts{LICENSE} = 'perl';
14 }
15 if ($MM_ver >= 6.46) {
16   $opts{META_MERGE} =
17     {
18      license => "perl",
19      resources =>
20      {
21       homepage => "http://imager.perl.org/",
22       repository => "git://git.imager.perl.org/imager-graph.git",
23       bugtracker => "http://rt.cpan.org/NoAuth/Bugs.html?Dist=Imager-Graph",
24      },
25     };
26 }
27
28 if ($MM_ver >= 6.48) {
29   $opts{MIN_PERL_VERSION} = "5.006";
30 }
31
32 WriteMakefile(
33               %opts,
34               'NAME'          => 'Imager::Graph',
35               'VERSION_FROM'  => 'Graph.pm', # finds $VERSION
36               PREREQ_PM       => 
37               { 
38                Imager=>'0.75',
39                'Test::More' => 0.47
40               },
41               clean => { FILES=>'testout' },
42 );