fix the version update test and update some versions
[imager-graph.git] / Makefile.PL
CommitLineData
bfcf9414
TC
1#!perl -w
2use strict;
3require 5.005;
35574351
TC
4use ExtUtils::MakeMaker;
5my %opts;
bfcf9414
TC
6# eval to prevent warnings about versions with _ in them
7my $MM_ver = eval $ExtUtils::MakeMaker::VERSION;
8if ($MM_ver > 6.06) {
35574351
TC
9 $opts{AUTHOR} = 'Tony Cook <tony@develop-help.com>';
10 $opts{ABSTRACT} = 'Draws good looking pie graphs';
11}
bfcf9414
TC
12if ($MM_ver >= 6.31) {
13 $opts{LICENSE} = 'perl';
14}
94011549
TC
15if ($MM_ver >= 6.46) {
16 $opts{META_MERGE} =
17 {
18 license => "perl",
19 resources =>
20 {
21 homepage => "http://imager.perl.org/",
9d6470db 22 repository => "git://git.imager.perl.org/imager-graph.git",
94011549
TC
23 bugtracker => "http://rt.cpan.org/NoAuth/Bugs.html?Dist=Imager-Graph",
24 },
25 };
26}
35574351 27
9d6470db
TC
28if ($MM_ver >= 6.48) {
29 $opts{MIN_PERL_VERSION} = "5.006";
30}
31
35574351
TC
32WriteMakefile(
33 %opts,
34 'NAME' => 'Imager::Graph',
35 'VERSION_FROM' => 'Graph.pm', # finds $VERSION
bfcf9414
TC
36 PREREQ_PM =>
37 {
f94f373e 38 Imager=>'0.75',
bfcf9414
TC
39 'Test::More' => 0.47
40 },
35574351
TC
41 clean => { FILES=>'testout' },
42);